问题现象: |
在win2k专业版+sp4的操作系统,装完860客户端登入系统门户提示信息:"门户,未知错误,请重新注册[DBNETLIB][Connectionopen(Connect())]SQL不存在或拒绝访问. |
问题原因: |
根据错误提示信息,应是登录端未能成功连接上数据服务器。 企业门户登录时首先需建立与应用服务器的链接,即企业门户中输入的服务器名称或ip地址;然后尝试链接【系统服务】-【应用服务器配置】中指定的数据源(即数据服务器名称或ip地址)。 |
解决方案: |
根据错误提示信息,应是登录端未能成功连接上数据服务器。 企业门户登录时首先需建立与应用服务器的链接,即企业门户中输入的服务器名称或ip地址;然后尝试链接【系统服务】-【应用服务器配置】中指定的数据源(即数据服务器名称或ip地址)。 与数据服务器链接不上主要有如下几种原因:
1、登录端尝试链接数据服务器名时,域名解析失败,无法成功解析服务器名称,建立链接失败; 参考解决方法:可尝试修改数据源配置,将数据源和数据服务器栏中填写数据服务器的ip地址,或修改本地host配置文件(可参考专题文章中850客户端链接失败案例分析);
2、登录端上是否已安装或安装过sqlserver数据库,客户端环境不‘干净’(可能regedit注册表中存在大量垃圾键值信息),导致客户端访问时默认寻找以前的sql服务器,但其已经不存在了; 参考解决方法:是否个别客户端存在此问题?考虑清理、更新环境。如果多个同环境的客户端均发生此问题,则不是此种原因所致,可跳过此『分析2』;
3、客户端登录门户时可以输入服务器的机器名或者ip地址,当输入ip地址时,应注意如下事项: IE中不可使用代理服务器,否则提示iis数据源配置错误等相关信息。 参考解决方法:请检查客户端登录方式是否为ip登录,并查看是否启用ie代理服务。
4、客户端可尝试使用telnet检测数据库服务器1433端口是否正常连通: 在开始--运行--cmd进入dos命令窗口,执行‘telnet 数据服务器名/ip 1433’可检测数据库端口,执行‘telnet 应用服务器名/ip 4630’可检测U8产品端口;需确保该些端口正常连接;
5、服务器端是否能成功进入企业门户?如果服务器端登录正常,请跳过。若不可登录,请检查服务器端iis是否可正常启动?数据源配置是否正确。 |
相关补丁: |
|
版本: |
8.60 |
模块: |
系统管理 |
产品: |
U860----企业门户 |
问题名称: |
860客户端登录提示SQL不存在或拒绝访问 |
最后更新: |
2005-06-28 00:00:00 |